Pale Moon for Linux optimized for Intel™ Atom

Starting with Pale Moon 27.0, we no longer provide our "generic" Atom optimized build for Linux.

If you were previously using the Atom optimized build, it is recommended that you upgrade to the mainline Linux build.

Old (unsupported!) versions of the Atom optimized build can still be found on the archived versions page.

Site design and Branding © 2015 Moonchild Productions - All rights reserved
Any other content is copyright or trademark to their respective owners.
This site uses Cookies - Your usage indicates your consent to their use.